Menu

Welcome, Guest. Please login or register.
Did you miss your activation email?
December 04, 2020, 08:14:56 am

Login with username, password and session length

Author Topic: Noggit help  (Read 6440 times)

Steff

  • Administrator
  • Creator of Worlds
  • *****
  • Posts: 4551
    • View Profile
Re: Noggit help
« Reply #15 on: July 14, 2012, 06:53:13 am »
Please repost your LAST config file and logfile.
« Last Edit: January 01, 1970, 01:00:00 am by Admin »
Please mark as solved if solved.
Don't ask if you could ask a question... JUST ask the Question.
You can send me also offline messages. I will answer if I get online.
Skype: project.modcraft
Discord: steff#6954

Gantrex1

  • Registred Member
  • BLP Convertor
  • *****
  • Posts: 13
    • View Profile
Re: Noggit help
« Reply #16 on: July 14, 2012, 09:58:10 am »
My Config:
Quote
# This is a config file tamplate. To use it rename into noggit.conf and set your optiones

#Edit this to your WoWFile!!!
Path = C:WoW 3.3.5

#Edit this to your Project-Directory and uncomment if you want to use it!
ProjectPath = C:WoWModdingMyProject

#Set this to the file where you will impor models from (the modelviewer log for example :) )
ImportFile  = C:UsersDanielDesktopProject1

#The Far clipping value. Set to 2048, 3072, 4096 etc. for a further look. Higher values need more 3d power.
#1024 is the standart value and will be taken if you do not set this value.
FarZ=1024

My Log:
Quote
4 - (Noggit.cpp:130): Noggit Studio - SDL 1.1
1727 - (Video.cpp:204): [Debug] GL: Version: 4.1.10834 Compatibility Profile Context
1727 - (Video.cpp:205): [Debug] GL: Vendor: ATI Technologies Inc.
1728 - (Video.cpp:206): [Debug] GL: Renderer: AMD Radeon HD 6320 Graphics    

 :?:
« Last Edit: January 01, 1970, 01:00:00 am by Admin »

Steff

  • Administrator
  • Creator of Worlds
  • *****
  • Posts: 4551
    • View Profile
Re: Noggit help
« Reply #17 on: July 14, 2012, 08:33:14 pm »
Is this the full log?
Whats the name of your config file?
« Last Edit: January 01, 1970, 01:00:00 am by Admin »
Please mark as solved if solved.
Don't ask if you could ask a question... JUST ask the Question.
You can send me also offline messages. I will answer if I get online.
Skype: project.modcraft
Discord: steff#6954

Gantrex1

  • Registred Member
  • BLP Convertor
  • *****
  • Posts: 13
    • View Profile
Re: Noggit help
« Reply #18 on: July 15, 2012, 12:07:54 am »
Yeah, that's it.
noggit.conf
« Last Edit: January 01, 1970, 01:00:00 am by Admin »

Steff

  • Administrator
  • Creator of Worlds
  • *****
  • Posts: 4551
    • View Profile
Re: Noggit help
« Reply #19 on: July 15, 2012, 11:15:18 am »
Try this config for testing


Quote
# This is a config file tamplate. To use it rename into noggit.conf and set your optiones

#Edit this to your WoWFile!!!
Path = C:WoW 3.3.5

#Edit this to your Project-Directory and uncomment if you want to use it!
#ProjectPath = C:WoWModdingMyProject

#Set this to the file where you will impor models from (the modelviewer log for example :) )
#ImportFile = C:UsersDanielDesktopProject1

#The Far clipping value. Set to 2048, 3072, 4096 etc. for a further look. Higher values need more 3d power.
#1024 is the standart value and will be taken if you do not set this value.
FarZ=1024
« Last Edit: January 01, 1970, 01:00:00 am by Admin »
Please mark as solved if solved.
Don't ask if you could ask a question... JUST ask the Question.
You can send me also offline messages. I will answer if I get online.
Skype: project.modcraft
Discord: steff#6954

Gantrex1

  • Registred Member
  • BLP Convertor
  • *****
  • Posts: 13
    • View Profile
Re: Noggit help
« Reply #20 on: July 15, 2012, 12:03:48 pm »
Still nothing. :(
« Last Edit: January 01, 1970, 01:00:00 am by Admin »

Steff

  • Administrator
  • Creator of Worlds
  • *****
  • Posts: 4551
    • View Profile
Re: Noggit help
« Reply #21 on: July 15, 2012, 12:06:07 pm »
Did the logfile change?
Try to update your Grafic Card Driver. If logfile stop there it cant init the video system.
« Last Edit: January 01, 1970, 01:00:00 am by Admin »
Please mark as solved if solved.
Don't ask if you could ask a question... JUST ask the Question.
You can send me also offline messages. I will answer if I get online.
Skype: project.modcraft
Discord: steff#6954

schlumpf

  • Administrator
  • Creator of Worlds
  • *****
  • Posts: 2967
    • View Profile
Re: Noggit help
« Reply #22 on: July 15, 2012, 01:17:52 pm »
The application is crashing during
Code: [Select]
 if( !video.init( xres, yres, fullscreen, doAntiAliasing ) )
  {
    LogError << "Initializing video failed." << std::endl;
    return -1;
  }

  SDL_WM_SetCaption( "Noggit Studio - " STRPRODUCTVER, "" );

  std::string wowpath( getGamePath() );
  if( wowpath == "" )
  {
    return -1;
  }

  Log << "Game path: " << wowpath << std::endl;
Where video.init() is the last to be called and contains
Code: [Select]
bool Video::init( int xres_, int yres_, bool fullscreen_, bool doAntiAliasing_ )
{
[...]

  LogDebug << "GL: Version: " << glGetString( GL_VERSION ) << std::endl;
  LogDebug << "GL: Vendor: " << glGetString( GL_VENDOR ) << std::endl;
  LogDebug << "GL: Renderer: " << glGetString( GL_RENDERER ) << std::endl;

  return mSupportCompression;
}
therefore has finished as it is printing everything. This means it is crashing in
Code: [Select]
 SDL_WM_SetCaption( "Noggit Studio - " STRPRODUCTVER, "" );

  std::string wowpath( getGamePath() );
  if( wowpath == "" )
  {
    return -1;
  }
So either SDL_WM_SetCaption or getGamePath. As I trust Sam

it will most likely not crash in SDL_WM_SetCaption. It therefore crashes in
Code: [Select]
std::string getGamePath()
{
  if( !boost::filesystem::exists( "NoggIt.conf" ) )
  {
  #ifdef _WIN32
    HKEY key;
    DWORD t;
    const DWORD s( 1024 );
    char temp[s];
    memset(temp,0,s);
    LONG l = RegOpenKeyEx(HKEY_LOCAL_MACHINE,"SOFTWARE\Wow6432Node\Blizzard Entertainment\World of Warcraft",0,KEY_QUERY_VALUE,&key);
    if (l != ERROR_SUCCESS)
      l = RegOpenKeyEx(HKEY_LOCAL_MACHINE,"SOFTWARE\Blizzard Entertainment\World of Warcraft\PTR",0,KEY_QUERY_VALUE,&key);
    if (l != ERROR_SUCCESS)
      l = RegOpenKeyEx(HKEY_LOCAL_MACHINE,"SOFTWARE\Blizzard Entertainment\World of Warcraft",0,KEY_QUERY_VALUE,&key);
    if (l == ERROR_SUCCESS && RegQueryValueEx(key,"InstallPath",0,&t,(LPBYTE)temp,(LPDWORD)&s) == ERROR_SUCCESS)
      return temp;
    else
      return "";
    RegCloseKey(key);
  #else
    return "/Applications/World of Warcraft/";
  #endif
  }
  else
  {
    Log << "Using config file." << std::endl;
    return ConfigFile( "NoggIt.conf" ).read<std::string>( "Path" );
  }
}
I don't think boost::filesystem::exists can crash. It therefore can either be true or false. As you are on windows, it either is
Code: [Select]
Log << "Using config file." << std::endl;
or some winapi calls.

Your log is not printing "Using config file.". Therefore, you do not have a properly named file.

It therefore seems like YOU ARE NOT HAVING A PROPER CONFIG FILE.

AND: That winapi stuff crashes on some configuration. I don't know why, but it might be protection with non-admin privileges — while I have no idea why you would need those. BUT I DON'T CARE.

You do NOT have a proper config file and noggit is crashing for some weird reason in windows specific code.

This is the last time I even remotely answer such a thread. This will be closed and moved to the bad topics as we had this problem often enough and the thread's title is just stupid and saying nothing.
« Last Edit: January 01, 1970, 01:00:00 am by Admin »