Menu

Welcome, Guest. Please login or register.
October 16, 2019, 04:18:19 am

Login with username, password and session length

Author Topic: [WOTLK]Animations f*cked up when editing models  (Read 837 times)

Makpptfox

  • Contributors
  • Loreweaver
  • *****
  • Posts: 103
    • View Profile
[WOTLK]Animations f*cked up when editing models
« on: June 17, 2018, 01:21:37 pm »
Hello there.

I was looking on the Saurfang's model and was bothered by his gigantic spaulder, so I had in mind to edit it, since it's not a submeshe I had to convert it with M2modRedux and import it as a M2i in blender.

While I edited tons of weapons to remove the physic elements from them (having those unmoving thing bother me like hell) I never tried to edit a big model, with animations and all.

I tried anyway, and in the end, the model works, but all the animations are completely doomed, at best when they works, they're not correct (like laughing when I jump, well I laughed too so it's something), at worst, I got a mesh explosion and thus, wow error.



I looked in the model and it miss a big, big part of it's data. I had no error while I imported and Exported with both M2Mod and Blender.

I use M2ModRedux 4.6.1 and Blender 2.73

So, my question is : Did I failed somewhere, and if it's the case, how do you edit it without destroying the model afterward ?

Regards :)
« Last Edit: June 17, 2018, 01:24:47 pm by Makpptfox »
For support, send your Discord's ID by PM.

Finsternis

  • Contributors
  • Creator of Worlds
  • *****
  • Posts: 493
    • View Profile

Makpptfox

  • Contributors
  • Loreweaver
  • *****
  • Posts: 103
    • View Profile
Re: [WOTLK]Animations f*cked up when editing models
« Reply #2 on: June 17, 2018, 03:28:43 pm »
Yes I Did.

The problem is definitly the final exported m2.

The original file is around 11mo, mine is 4mo.

Here's the animations templates :

The working saurfang's m2 (with the spaulder)


And here's mine
For support, send your Discord's ID by PM.

Finsternis

  • Contributors
  • Creator of Worlds
  • *****
  • Posts: 493
    • View Profile
Re: [WOTLK]Animations f*cked up when editing models
« Reply #3 on: June 17, 2018, 06:14:53 pm »
Hm then i have no idea. This missing animationĀ“s are strange.

Makpptfox

  • Contributors
  • Loreweaver
  • *****
  • Posts: 103
    • View Profile
Re: [WOTLK]Animations f*cked up when editing models
« Reply #4 on: June 21, 2018, 01:19:45 am »
Well, If anyone know an uptodate way to edit animated M2s, i'm willing to learn.

It must be me who's failing somewhere in the process of editing this badboy.
For support, send your Discord's ID by PM.