Menu

Welcome, Guest. Please login or register.
Did you miss your activation email?
April 21, 2019, 10:03:13 pm

Login with username, password and session length

Recent Posts

Pages: [1] 2 3 ... 10
1
Serverside Modding / [3.3.5a] Creating a custom class problems
« Last post by niurka123 on April 19, 2019, 01:15:11 am »
I've been trying to make a new class in TrinityCore for the last few days, but all the guides I followed are incomplete or outdated, and I compile the core I get syntax errors I can't fix. Also, the guides I follow have archives or lines that my server don't have or ones that only exist for Arcemu, MaNGOS or Eluna.

I only managed to get the constant message: “Player 12 has incorrect race/class pair. Don't build enum” When gets on the character list. I wasn't able to fix that too. The few I managed to get was only to fix races, not classes.

I tried to modify the corresponding dbc and tables in Sqlyog and the lines in the core, but that didn't work either. I don't know what to do anymore.

Sry for my bad english and please.. help me ;^;
2
"Retro-Porting" / Re: [RELEASE] [WotLk] Creature Models for Wotlk
« Last post by Finsternis on April 18, 2019, 04:00:28 pm »
Hello, these models have bad textures.
I will look on it .

So i made again a eventmod. This time Eastern!
The bear mounts now bunnys (super cool xD!)
I edit  the barrels again and the green and blue puppet in dalaran.
This mod ist not 100% perfect but it is just a event mod.
I will delete this post after eastern again.
I hope you liked the hand drawn stuff.
Happy Eastern^^

3
Noggit / Re: Error Custom Dungeon/Instance 5 Man
« Last post by schlumpf on April 18, 2019, 08:29:04 am »
and what error do you get?
4
Noggit / Error Custom Dungeon/Instance 5 Man
« Last post by Addikted on April 17, 2019, 05:31:20 pm »
Hey there,
I'm making a custom instance/dungeon 5 man.

Everything works fine, I can teleport to my custom map if I set the map type to 0 (normal map) but if I change it to 1 (dungeon/party 5man) I can't teleport anymore.
Yes, I made 2 entries on MapDifficulty.dbc (for type 0 normal, 1 heroic modes) and still is not working.

Any solution please?
5
Resources and Tools / [TOOL] Legion -> Wotlk Multi Converter
« Last post by Adspartan on April 17, 2019, 03:24:25 pm »
Since I'm no longer updating it here are the sources of my downporter:
https://mega.nz/#!qd030AxD!4yurYl1S6xLSt1PfemBj-c9immeP5EfM3JWVTXi5Q_w

I won't provide any support but feel free to do whatever you want with the sources.

A big thanks again to:
- All those who contributed / are contributing to the wiki which was my sole source of information on the file formats
- Mjollna for her m2 converter and awesome ADT diagram!
- PhillipTNG for his m2 conversion script which helped me getting started.

Have fun.
6
General / [Mangos][1.12.1] Help adding a new mount
« Last post by Ayos on April 16, 2019, 06:50:33 pm »
Hi!
I have some issue with adding a new mount to my server, and I hope some of you may know the answer to my problem!

So, I was planning to add the Venomhide raptor mount to the game as a little practice, with reputation and quests similar to the Winterspring Frostsaber's.
The reputation/npcs/quests were easy, but I had one issue with the mount. The item itself shows properly, but if I click on it, it gets casted but the casting stops at the end of the casting bar and the mount never gets summoned.
The casting bar text shows the proper spell name aswell.

What I have done so far:
- Added the mount creature to the creature_template table.
- Added the item to the item_templates table.
- Added the spell to the spell_templates table.
- Added the spell to the Spells.dbc.
I did those, by copying an existing mount, editing a few basic fields, and linking the IDs properly (hopefully, but checked it and seemed right).
And I'm using the Elysium Core V4.

So, what did I miss / where did it go wrong?
If anybody knows, I would be really grateful!
7
General / Old Outland for Vanilla (files included)
« Last post by Ayos on April 16, 2019, 06:49:39 pm »
Hi!
I just found the old outland files so I tought I share them.
Just copy the patch file to your vanilla wow data directory (and probably to the server maps folder too).
https://drive.google.com/file/d/13Eaya4KBfGnoEoKeq1Dw7wM9yyuTVkC-/view?usp=sharing
And here are the command with coords: .go -14882 12928 10 534
The 534 is probably 0 or 1 though.
Enjoy!
8
"Retro-Porting" / Re: [Release] WoD Character Models (CL, BC, LK)
« Last post by diosnatur on April 16, 2019, 04:15:28 am »
I probably won't release a version for Cataclysm, I have to pick a place to stop or else I'll be doing this forever. I could share the pre-retroported models with anyone that wants them though.

That would be great, it hurts that I do not know how to make the patches and everything custom.
9
"Retro-Porting" / Re: [Release] WoD Character Models (CL, BC, LK)
« Last post by leeviathan on April 15, 2019, 04:04:04 pm »
I probably won't release a version for Cataclysm, I have to pick a place to stop or else I'll be doing this forever. I could share the pre-retroported models with anyone that wants them though.
10
"Retro-Porting" / Re: [RELEASE] [WotLk] Creature Models for Wotlk
« Last post by terrorbringer on April 13, 2019, 07:44:54 pm »
Hello, these models have bad textures.
Pages: [1] 2 3 ... 10